odd behavior

Post comments about Shareaza code and discuss with other developers.
Forum rules
Home | Wiki | Rules

odd behavior

Postby yousry » 27 Sep 2009 20:59

Hi

I having an odd behavior after successfully compiling shareaza with MVS2008
every thing compiles fine, and I ran the installer without any problem, but when I run shareaza, nothing in it responds or seem to do anything. the menus are not shown, clicking any tab doesn't do anything.
I uploaded an image of it here http://img.imageshack.us/i/shareaza.jpg/
anything I need to do to make it work?

I know I can use the installer from the site, and in that case it works fine, but I need to modify it to let me seed files not in the incomplete folder


(I didn't modify anything yet, nothing changed in the sources (except the reference to the RazaWebHook64.dll in main_9.iss), other than this, it is exactly as downloaded from the svn)

thanks for the help
yousry
 
Posts: 1
Joined: 27 Sep 2009 20:41

Re: odd behavior

Postby raspopov » 26 Oct 2009 20:39

Just run Shareaza under debugger and when it hungs press Pause button and dump callstacks of every thread.
User avatar
raspopov
Project Admin
 
Posts: 539
Joined: 13 Jun 2009 12:30
Location: Russian Federation

Re: odd behavior

Postby siavoshkc » 06 Nov 2009 19:48

I am 90 percent sure the soulution is not perfectly compiled. Try rebuilding soulution "Ctrl+Alt+F7". Then "Ctrl+\, Ctrl+E" to see the list of errors.
siavoshkc
 
Posts: 288
Joined: 02 Nov 2009 09:37


Return to Development Discussion

Who is online

Users browsing this forum: No registered users and 1 guest