GNUTELLA1 DEAD?

Get answers to your Shareaza related problems.
Forum rules
Home | Wiki | Rules

GNUTELLA1 DEAD?

Postby hpoindexter » 03 Aug 2012 16:07

I have been following all the posts about connection problems with GNUTELLA1 for the past month and I keep wondering is the system still working or is it DEAD?
hpoindexter
 
Posts: 3
Joined: 03 Aug 2012 15:58

Re: GNUTELLA1 DEAD?

Postby cyko_01 » 03 Aug 2012 21:46

the gnutella1 network is still alive - once you get connected everything works fine(for a while) - but I think shareaza is maybe having problems communicating with GWCs
Join Shareaza On Facebook! --> http://facebook.com/Shareaza
All-In-One AntiSpam Filter [Aug-14-2011] --> http://forum.sure-raza.com/viewtopic.php?f=2&t=10

Image
User avatar
cyko_01
 
Posts: 928
Joined: 13 Jun 2009 15:51

Re: GNUTELLA1 DEAD?

Postby pokerfan » 12 Aug 2012 13:46

I noticed my 64bit Shareaza wasn't connecting to G1 also so I started looking around and found the solution.

In Shareaza Settings, Advanced change the Discovery.EnableG1GWC item to True. Discovery of G1 hosts will start immediately when you click Apply (assuming you have G1 discovery services registered).
De Do Do Do De Da Da Da
Is all I want to say to you.
(The Police)
pokerfan
 
Posts: 3
Joined: 12 Aug 2012 13:07

Re: GNUTELLA1 DEAD?

Postby cyko_01 » 12 Aug 2012 13:52

pokerfan wrote:In Shareaza Settings, Advanced change the Discovery.EnableG1GWC item to True. Discovery of G1 hosts will start immediately when you click Apply (assuming you have G1 discovery services registered).

whoa! that works. G2 started connecting shortly after too! My question is... how did that get to be disabled by default?!!!!
Join Shareaza On Facebook! --> http://facebook.com/Shareaza
All-In-One AntiSpam Filter [Aug-14-2011] --> http://forum.sure-raza.com/viewtopic.php?f=2&t=10

Image
User avatar
cyko_01
 
Posts: 928
Joined: 13 Jun 2009 15:51

Re: GNUTELLA1 DEAD?

Postby pokerfan » 12 Aug 2012 14:28

My guess is it was due to testing. I imagine the developers turn off various components while testing others and possibly someone forgot to re-enable it during the build.
De Do Do Do De Da Da Da
Is all I want to say to you.
(The Police)
pokerfan
 
Posts: 3
Joined: 12 Aug 2012 13:07

Re: GNUTELLA1 DEAD?

Postby cherrybomb666 » 14 Aug 2012 13:33

wow, i have been having this issue for months and got zero replies when i posted about it. when i go to shareaza settings i don't see an advanced option.
cherrybomb666
 
Posts: 5
Joined: 17 Feb 2011 16:11

Re: GNUTELLA1 DEAD?

Postby cyko_01 » 14 Aug 2012 14:22

cherrybomb666 wrote:wow, i have been having this issue for months and got zero replies when i posted about it. when i go to shareaza settings i don't see an advanced option.

You need to be in power mode (view > power mode) to see the advanced settings
Join Shareaza On Facebook! --> http://facebook.com/Shareaza
All-In-One AntiSpam Filter [Aug-14-2011] --> http://forum.sure-raza.com/viewtopic.php?f=2&t=10

Image
User avatar
cyko_01
 
Posts: 928
Joined: 13 Jun 2009 15:51

Re: GNUTELLA1 DEAD?

Postby cherrybomb666 » 14 Aug 2012 23:25

hooray! thank you kindly
cherrybomb666
 
Posts: 5
Joined: 17 Feb 2011 16:11

Re: GNUTELLA1 DEAD?

Postby profyler1 » 24 Aug 2012 18:30

thx!! hope developers sees this topic
profyler1
 
Posts: 39
Joined: 21 Mar 2011 18:35

Re: GNUTELLA1 DEAD?

Postby hpoindexter » 04 Sep 2012 08:28

Thanks to pokerfan! GNUTELLA1 is alive and well on my system :D
hpoindexter
 
Posts: 3
Joined: 03 Aug 2012 15:58

Re: GNUTELLA1 DEAD?

Postby nutluck » 05 Sep 2012 20:20

I was having the same problem as well. That fixed it, so thanks.
nutluck
 
Posts: 1
Joined: 05 Sep 2012 20:20

Re: GNUTELLA1 DEAD?

Postby pinkfloydeffect » 15 Sep 2012 16:18

This does not work for me, I pass all connection tests, Discovery.EnableG1GWC is true/enabled and G2 connects along with eDonkey but G1 & DC++ do not connect. I have "connected" everything in the Host Cache (only says eDonkey though) I also Query all the links in the discovery services... why won't they connect?!
pinkfloydeffect
 
Posts: 9
Joined: 30 Aug 2012 22:32

Re: GNUTELLA1 DEAD? Fixed

Postby scs66 » 10 Oct 2012 13:03

Discovery.EnableG1GWC True instead of False

Was it really that simple !? Yes! On 2 different computers.

Unbelievable !!

Come on dear developers !
I really admire your effort, and have deep respect for your time investment in this project.

But this is a bit :oops:

If so many people have troubles with this, why not a new fixed release ?
Is it so much work to release a corrected version?
For my and other "Just Users" understanding, how much time/work is it to change a corrected beta to real version?

Maybe it was fixed in a beta, but my experience is that Beta's are running slower and sludgier because of the extra code. And that they are not adviced.
Should we try beta's more often?
scs66
 
Posts: 5
Joined: 02 May 2011 17:21

Re: GNUTELLA1 DEAD?

Postby raspopov » 13 Oct 2012 06:35

This code is a part of Shareaza since 25.06.2007 (implemented by ale5000).

Hmm... Shareaza always prefer G1 UDP-caches and "Discovery.EnableG1GWC" option enables G1 WEB-caches using. At current time no G1 UDP-caches exist.

UPD: Fixed in r9216.
User avatar
raspopov
Project Admin
 
Posts: 539
Joined: 13 Jun 2009 12:30
Location: Russian Federation

Re: GNUTELLA1 DEAD?

Postby scs66 » 14 Oct 2012 22:39

I had to take some time to see what you mean:
So this parameter Discovery.EnableG1GWC has been False for a long time, and it tells Aza to use UDP caches.
These caches seem to be gone and that is the real problem.

Changing it to true is actually a workaround, using an alternative cache-system.

BTW My problem of sometimes very slow G2 connecting is now also fixed with this parameter.
scs66
 
Posts: 5
Joined: 02 May 2011 17:21

Re: GNUTELLA1 DEAD?

Postby punkmaister » 27 Nov 2012 01:07

pinkfloydeffect wrote:This does not work for me, I pass all connection tests, Discovery.EnableG1GWC is true/enabled and G2 connects along with eDonkey but G1 & DC++ do not connect. I have "connected" everything in the Host Cache (only says eDonkey though) I also Query all the links in the discovery services... why won't they connect?!


Didn't work for me either, :( someone said one should be registered to G1 but how does one do that?
punkmaister
 
Posts: 104
Joined: 10 Aug 2009 04:09

Re: GNUTELLA1 DEAD?

Postby old_death » 27 Nov 2012 11:34

pinkfloydeffect wrote:This does not work for me, I pass all connection tests, Discovery.EnableG1GWC is true/enabled and G2 connects along with eDonkey but G1 & DC++ do not connect. I have "connected" everything in the Host Cache (only says eDonkey though) I also Query all the links in the discovery services... why won't they connect?!
You can show the host cache for the other networks by selecting the corresponding buttons below the host list.
User avatar
old_death
 
Posts: 1630
Joined: 13 Jun 2009 16:19


Return to Help and Support

Who is online

Users browsing this forum: No registered users and 1 guest